Build AOSP(Android 11) ARM image for Emlator

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Build AOSP(Android 11) ARM image for Emlator

feng han

https://ci.android.com/builds/submitted/7176368/aarch64_sdk_tools_linux/latest
https://ci.android.com/builds/submitted/7223358/sdk_arm64-sdk/latest

I downloaded the latest ARM emulator and ARM system images from the above URLs. I have successfully ran the emulator,
then type adb devices, the device is OK: emulator-5554

However when, I connect to it via adb connect localhost:5555 and then type adb devices, I get the following: localhost:5555 offline,

111.png

ERROE MSG:

hwservicemanager: Since android.hardware.media.omx@1.0::IOmxStore/default is not registered, trying to start it as a lazy HAL. HidlServiceManagement: getService: Trying again for android.hardware.media.omx@1.0::IOmxStore/default... Unable to set property "ctl.interface_start" to "android.hardware.media.omx@1.0::IOmxStore/default": error code: 0x20 Control message: Could not find 'android.hardware.media.omx@1.0::IOmxStore/default' for ctl.interface_start from pid: 222 (/system/bin/hwservicemanager) init: Control message: Could not find 'android.hardware.media.omx@1.0::IOmxStore/default' for ctl.interface_start from pid: 225 (/system/bin/hwservicemanager) 

2222.png

--
You received this message because you are subscribed to the Google Groups "android-platform" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/android-platform/c8d8cc74-7668-463b-8bea-8ce6a30262c6n%40googlegroups.com.
Reply | Threaded
Open this post in threaded view
|

Re: Build AOSP(Android 11) ARM image for Emlator

MD Khair

On Tue, Mar 23, 2021, 11:54 PM feng han <[hidden email]> wrote:

https://ci.android.com/builds/submitted/7176368/aarch64_sdk_tools_linux/latest
https://ci.android.com/builds/submitted/7223358/sdk_arm64-sdk/latest

I downloaded the latest ARM emulator and ARM system images from the above URLs. I have successfully ran the emulator,
then type adb devices, the device is OK: emulator-5554

However when, I connect to it via adb connect localhost:5555 and then type adb devices, I get the following: localhost:5555 offline,

111.png

ERROE MSG:

hwservicemanager: Since android.hardware.media.omx@1.0::IOmxStore/default is not registered, trying to start it as a lazy HAL. HidlServiceManagement: getService: Trying again for android.hardware.media.omx@1.0::IOmxStore/default... Unable to set property "ctl.interface_start" to "android.hardware.media.omx@1.0::IOmxStore/default": error code: 0x20 Control message: Could not find 'android.hardware.media.omx@1.0::IOmxStore/default' for ctl.interface_start from pid: 222 (/system/bin/hwservicemanager) init: Control message: Could not find 'android.hardware.media.omx@1.0::IOmxStore/default' for ctl.interface_start from pid: 225 (/system/bin/hwservicemanager) 

2222.png

--
You received this message because you are subscribed to the Google Groups "android-platform" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/android-platform/c8d8cc74-7668-463b-8bea-8ce6a30262c6n%40googlegroups.com.

--
You received this message because you are subscribed to the Google Groups "android-platform" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/android-platform/CAC5tZoay5BKASt2uUkWGAq2Ac478zyPp7SwSEQPpjxWF4s21OA%40mail.gmail.com.
Reply | Threaded
Open this post in threaded view
|

Re: Build AOSP(Android 11) ARM image for Emlator

Travis Williams
In reply to this post by feng han

On Tue, Mar 23, 2021, 12:54 PM feng han <[hidden email]> wrote:

https://ci.android.com/builds/submitted/7176368/aarch64_sdk_tools_linux/latest
https://ci.android.com/builds/submitted/7223358/sdk_arm64-sdk/latest

I downloaded the latest ARM emulator and ARM system images from the above URLs. I have successfully ran the emulator,
then type adb devices, the device is OK: emulator-5554

However when, I connect to it via adb connect localhost:5555 and then type adb devices, I get the following: localhost:5555 offline,

111.png

ERROE MSG:

hwservicemanager: Since android.hardware.media.omx@1.0::IOmxStore/default is not registered, trying to start it as a lazy HAL. HidlServiceManagement: getService: Trying again for android.hardware.media.omx@1.0::IOmxStore/default... Unable to set property "ctl.interface_start" to "android.hardware.media.omx@1.0::IOmxStore/default": error code: 0x20 Control message: Could not find 'android.hardware.media.omx@1.0::IOmxStore/default' for ctl.interface_start from pid: 222 (/system/bin/hwservicemanager) init: Control message: Could not find 'android.hardware.media.omx@1.0::IOmxStore/default' for ctl.interface_start from pid: 225 (/system/bin/hwservicemanager) 

2222.png

--
You received this message because you are subscribed to the Google Groups "android-platform" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/android-platform/c8d8cc74-7668-463b-8bea-8ce6a30262c6n%40googlegroups.com.

--
You received this message because you are subscribed to the Google Groups "android-platform" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/android-platform/CANO4nMFK-3XGkcwHLq7UeWWm2FcJ8X7GHsrVisqD_Or%3DHTB7vw%40mail.gmail.com.

_DCIM_CATCH_1616194539711.jpg (2M) Download Attachment