Cannot setup build environment in Ubuntu 18.04

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Cannot setup build environment in Ubuntu 18.04

Kushtrim Pacaj

I am trying to setup a new build server for AOSP and ran into problems setting up the environment.
I've done this lots of times without problems, but something seems to have changed.

This is a fresh install of Ubuntu 18.04.4 LTS.
What I'm trying to install is this ( from this link https://source.android.com/setup/build/initializing )


sudo apt-get install git-core gnupg flex bison build-essential zip curl zlib1g-dev gcc-multilib g++-multilib libc6-dev-i386 lib32ncurses5-dev x11proto-core-dev libx11-dev lib32z1-dev libgl1-mesa-dev libxml2-utils xsltproc unzip fontconfig


This is the output:  

Building dependency tree      

Reading state information... Done

fontconfig is already the newest version (2.11.94-0ubuntu1.1).

fontconfig set to manually installed.

curl is already the newest version (7.58.0-2ubuntu3.9).

curl set to manually installed.

build-essential is already the newest version (12.4ubuntu1).

build-essential set to manually installed.

gnupg is already the newest version (2.2.4-1ubuntu1.2).

gnupg set to manually installed.

Some packages could not be installed. This may mean that you have

requested an impossible situation or if you are using the unstable

distribution that some required packages have not yet been created

or been moved out of Incoming.

The following information may help to resolve the situation:


The following packages have unmet dependencies:

g++-multilib : Depends: g++-5-multilib (>= 5.3.1-3~) but it is not going to be installed

gcc-multilib : Depends: gcc-5-multilib (>= 5.3.1-3~) but it is not going to be installed

lib32ncurses5-dev : Depends: lib32tinfo5 (= 6.0+20160213-1ubuntu1) but it is not going to be installed

                    Depends: lib32ncurses5 (= 6.0+20160213-1ubuntu1) but it is not going to be installed

                    Depends: lib32tinfo-dev (= 6.0+20160213-1ubuntu1) but it is not going to be installed

                    Depends: libncurses5-dev (= 6.0+20160213-1ubuntu1) but it is not going to be installed

lib32z1-dev : Depends: lib32z1 (= 1:1.2.8.dfsg-2ubuntu4.3) but it is not going to be installed

libc6-dev-i386 : Depends: libc6-i386 (= 2.23-0ubuntu11.2) but it is not going to be installed

                 Depends: libc6-dev (= 2.23-0ubuntu11.2) but 2.27-3ubuntu1.2 is to be installed

libgl1-mesa-dev : Depends: mesa-common-dev (= 18.0.5-0ubuntu0~16.04.1) but it is not going to be installed

                  Depends: libdrm-dev (>= 2.4.74) but it is not going to be installed

                  Depends: libx11-xcb-dev but it is not going to be installed

                  Depends: libxcb-dri3-dev but it is not going to be installed

                  Depends: libxcb-present-dev but it is not going to be installed

                  Depends: libxcb-sync-dev but it is not going to be installed

                  Depends: libxcb-dri2-0-dev but it is not going to be installed

                  Depends: libxcb-glx0-dev but it is not going to be installed

libx11-dev : Depends: libx11-6 (= 2:1.6.3-1ubuntu2.1) but 2:1.6.4-3ubuntu0.2 is to be installed

             Depends: libxau-dev (>= 1:1.0.0-1) but it is not going to be installed

             Depends: libxdmcp-dev (>= 1:1.0.0-1) but it is not going to be installed

             Depends: libxcb1-dev but it is not going to be installed

             Recommends: libx11-doc but it is not going to be installed

zlib1g-dev : Depends: zlib1g (= 1:1.2.8.dfsg-2ubuntu4.3) but 1:1.2.11.dfsg-0ubuntu2 is to be installed

E: Unable to correct problems, you have held broken packages.



--
--
You received this message because you are subscribed to the "Android Building" mailing list.
To post to this group, send email to [hidden email]
To unsubscribe from this group, send email to
[hidden email]
For more options, visit this group at
http://groups.google.com/group/android-building?hl=en

---
You received this message because you are subscribed to the Google Groups "Android Building" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/android-building/5e66de0c-a7a0-4777-bbb0-fd8517cc150ao%40googlegroups.com.
Reply | Threaded
Open this post in threaded view
|

Cannot setup build environment in Ubuntu 18.04

Vladimir Belousov
We are making a build based on https://qiita.com/osakiy/items/e338f0be3bb7cabeab5d
Everything works correctly.

--
--
You received this message because you are subscribed to the "Android Building" mailing list.
To post to this group, send email to [hidden email]
To unsubscribe from this group, send email to
[hidden email]
For more options, visit this group at
http://groups.google.com/group/android-building?hl=en

---
You received this message because you are subscribed to the Google Groups "Android Building" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/android-building/7fc3f2d2-76f6-42ba-ae66-27add1fbad3fo%40googlegroups.com.
Reply | Threaded
Open this post in threaded view
|

Re: Cannot setup build environment in Ubuntu 18.04

Sooraj Sizon
In reply to this post by Kushtrim Pacaj

Have you tried to downgrade zlib1g package to the required version, and the install should succeed afterwards.

On Saturday, August 1, 2020 at 10:04:37 PM UTC+5:30, Kushtrim Pacaj wrote:

I am trying to setup a new build server for AOSP and ran into problems setting up the environment.
I've done this lots of times without problems, but something seems to have changed.

This is a fresh install of Ubuntu 18.04.4 LTS.
What I'm trying to install is this ( from this link <a href="https://source.android.com/setup/build/initializing" style="font-family:Arial,Helvetica,sans-serif;font-size:13px" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://source.android.com/setup/build/initializing&#39;;return true;" onclick="this.href=&#39;https://source.android.com/setup/build/initializing&#39;;return true;">https://source.android.com/setup/build/initializing )


sudo apt-get install git-core gnupg flex bison build-essential zip curl zlib1g-dev gcc-multilib g++-multilib libc6-dev-i386 lib32ncurses5-dev x11proto-core-dev libx11-dev lib32z1-dev libgl1-mesa-dev libxml2-utils xsltproc unzip fontconfig


This is the output:  

Building dependency tree      

Reading state information... Done

fontconfig is already the newest version (2.11.94-0ubuntu1.1).

fontconfig set to manually installed.

curl is already the newest version (7.58.0-2ubuntu3.9).

curl set to manually installed.

build-essential is already the newest version (12.4ubuntu1).

build-essential set to manually installed.

gnupg is already the newest version (2.2.4-1ubuntu1.2).

gnupg set to manually installed.

Some packages could not be installed. This may mean that you have

requested an impossible situation or if you are using the unstable

distribution that some required packages have not yet been created

or been moved out of Incoming.

The following information may help to resolve the situation:


The following packages have unmet dependencies:

g++-multilib : Depends: g++-5-multilib (>= 5.3.1-3~) but it is not going to be installed

gcc-multilib : Depends: gcc-5-multilib (>= 5.3.1-3~) but it is not going to be installed

lib32ncurses5-dev : Depends: lib32tinfo5 (= 6.0+20160213-1ubuntu1) but it is not going to be installed

                    Depends: lib32ncurses5 (= 6.0+20160213-1ubuntu1) but it is not going to be installed

                    Depends: lib32tinfo-dev (= 6.0+20160213-1ubuntu1) but it is not going to be installed

                    Depends: libncurses5-dev (= 6.0+20160213-1ubuntu1) but it is not going to be installed

lib32z1-dev : Depends: lib32z1 (= 1:1.2.8.dfsg-2ubuntu4.3) but it is not going to be installed

libc6-dev-i386 : Depends: libc6-i386 (= 2.23-0ubuntu11.2) but it is not going to be installed

                 Depends: libc6-dev (= 2.23-0ubuntu11.2) but 2.27-3ubuntu1.2 is to be installed

libgl1-mesa-dev : Depends: mesa-common-dev (= 18.0.5-0ubuntu0~16.04.1) but it is not going to be installed

                  Depends: libdrm-dev (>= 2.4.74) but it is not going to be installed

                  Depends: libx11-xcb-dev but it is not going to be installed

                  Depends: libxcb-dri3-dev but it is not going to be installed

                  Depends: libxcb-present-dev but it is not going to be installed

                  Depends: libxcb-sync-dev but it is not going to be installed

                  Depends: libxcb-dri2-0-dev but it is not going to be installed

                  Depends: libxcb-glx0-dev but it is not going to be installed

libx11-dev : Depends: libx11-6 (= 2:1.6.3-1ubuntu2.1) but 2:1.6.4-3ubuntu0.2 is to be installed

             Depends: libxau-dev (>= 1:1.0.0-1) but it is not going to be installed

             Depends: libxdmcp-dev (>= 1:1.0.0-1) but it is not going to be installed

             Depends: libxcb1-dev but it is not going to be installed

             Recommends: libx11-doc but it is not going to be installed

zlib1g-dev : Depends: zlib1g (= 1:1.2.8.dfsg-2ubuntu4.3) but 1:1.2.11.dfsg-0ubuntu2 is to be installed

E: Unable to correct problems, you have held broken packages.



--
--
You received this message because you are subscribed to the "Android Building" mailing list.
To post to this group, send email to [hidden email]
To unsubscribe from this group, send email to
[hidden email]
For more options, visit this group at
http://groups.google.com/group/android-building?hl=en

---
You received this message because you are subscribed to the Google Groups "Android Building" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/android-building/32afd4df-6b8c-4429-b816-28fdfe59dc06o%40googlegroups.com.
Reply | Threaded
Open this post in threaded view
|

Re: Cannot setup build environment in Ubuntu 18.04

Kushtrim Pacaj
In reply to this post by Kushtrim Pacaj
@Sooraj, thank you for you reponse:

I downgraded zlib1g, and the error for that package seems to have gone away, but I cannot seem to do the same for others.... Especially libc6, as that seems to provide a warning that it will delete core stuff:


The following packages have unmet dependencies:
 g
++-multilib : Depends: g++-5-multilib (>= 5.3.1-3~) but it is not going to be installed
 gcc
-multilib : Depends: gcc-5-multilib (>= 5.3.1-3~) but it is not going to be installed
 lib32ncurses5
-dev : Depends: lib32tinfo5 (= 6.0+20160213-1ubuntu1) but it is not going to be installed
                     
Depends: lib32ncurses5 (= 6.0+20160213-1ubuntu1) but it is not going to be installed
                     
Depends: lib32tinfo-dev (= 6.0+20160213-1ubuntu1) but it is not going to be installed
                     
Depends: libncurses5-dev (= 6.0+20160213-1ubuntu1) but it is not going to be installed
 lib32z1
-dev : Depends: lib32z1 (= 1:1.2.8.dfsg-2ubuntu4.3) but it is not going to be installed
 libc6
-dev-i386 : Depends: libc6-i386 (= 2.23-0ubuntu11.2) but it is not going to be installed
                 
Depends: libc6-dev (= 2.23-0ubuntu11.2) but 2.27-3ubuntu1.2 is to be installed
 libgl1
-mesa-dev : Depends: mesa-common-dev (= 18.0.5-0ubuntu0~16.04.1) but it is not going to be installed
                   
Depends: libdrm-dev (>= 2.4.74) but it is not going to be installed
                   
Depends: libx11-xcb-dev but it is not going to be installed
                   
Depends: libxcb-dri3-dev but it is not going to be installed
                   
Depends: libxcb-present-dev but it is not going to be installed
                   
Depends: libxcb-sync-dev but it is not going to be installed
                   
Depends: libxcb-dri2-0-dev but it is not going to be installed
                   
Depends: libxcb-glx0-dev but it is not going to be installed
 libx11
-dev : Depends: libxau-dev (>= 1:1.0.0-1) but it is not going to be installed
             
Depends: libxdmcp-dev (>= 1:1.0.0-1) but it is not going to be installed
             
Depends: libxcb1-dev but it is not going to be installed
E
: Unable to correct problems, you have held broken packages.
username@build
-agent08:~$ sudo apt-get insall libxau-dev=1:1.0.0-1
E
: Invalid operation insall
username@build
-agent08:~$ sudo apt-get install libxau-dev=1:1.0.0-1
Reading package lists... Done
Building dependency tree      
Reading state information... Done
E
: Version '1:1.0.0-1' for 'libxau-dev' was not found
username@build
-agent08:~$ sudo apt-get install ibxdmcp-dev=1:1.0.0-1
Reading package lists... Done
Building dependency tree      
Reading state information... Done
E
: Unable to locate package ibxdmcp-dev
username@build
-agent08:~$ sudo apt-get install libxdmcp-dev=1:1.0.0-1
Reading package lists... Done
Building dependency tree      
Reading state information... Done
E
: Version '1:1.0.0-1' for 'libxdmcp-dev' was not found
username@build
-agent08:~$ sudo apt-get install lib32tinfo5=6.0+20160213-1ubuntu1
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation
or if you are using the unstable
distribution that some required packages have
not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:


The following packages have unmet dependencies:
 lib32tinfo5
: Depends: libc6-i386 (>= 2.16) but it is not going to be installed
E
: Unable to correct problems, you have held broken packages.
username@build
-agent08:~$ sudo apt-get install libc6-i386=2.23-0ubuntu11.2
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation
or if you are using the unstable
distribution that some required packages have
not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:


The following packages have unmet dependencies:
 libc6
-i386 : Depends: libc6 (= 2.23-0ubuntu11.2) but 2.27-3ubuntu1.2 is to be installed
E
: Unable to correct problems, you have held broken packages.
username@build
-agent08:~$ sudo apt-get install libc6=2.23-0ubuntu11.2
Reading package lists... Done
Building dependency tree      
Reading state information... Done
The following packages were automatically installed and are no longer required:
  acl apport
-symptoms bc binutils-common busybox-initramfs command-not-found-data cpp cpp-7 distro-info-data dns-root-data dpkg-repack ebtables fakeroot geoip-database gettext-base git-man
  gnupg
-l10n gnupg-utils gpg gpg-agent gpg-wks-server gpgconf gpgsm gpgv groff-base isc-dhcp-common iso-codes klibc-utils krb5-locales libalgorithm-diff-perl libalgorithm-diff-xs-perl
  libalgorithm
-merge-perl libapparmor1 libargon2-0 libasan4 libasn1-8-heimdal libassuan0 libatm1 libatomic1 libbinutils libcc1-0 libcilkrts5 libdpkg-perl libdrm-common libdrm2 libedit2
  liberror
-perl libestr0 libevent-2.1-6 libfakeroot libfastjson4 libffi6 libfile-fcntllock-perl libfribidi0 libfuse2 libgcc-7-dev libgeoip1 libglib2.0-data libgomp1 libgssapi3-heimdal
  libhcrypto4
-heimdal libheimbase1-heimdal libheimntlm0-heimdal libhogweed4 libhx509-5-heimdal libicu60 libidn2-0 libisl19 libitm1 libjson-c3 libk5crypto3 libklibc libkrb5-26-heimdal
  libkrb5
-3 libkrb5support0 libksba8 libldap-common liblsan0 liblwres160 liblzo2-2 libmpc3 libmpdec2 libmpx2 libmspack0 libnewt0.52 libnghttp2-14 libnpth0 libntfs-3g88 libnuma1 libpcap0.8
  libpipeline1 libpsl5 libquadmath0 libreadline5 libroken18
-heimdal libsasl2-2 libsasl2-modules-db libseccomp2 libslang2 libsqlite3-0 libssl1.0.0 libtasn1-6 libtsan0 libubsan0 libunistring2
  libuv1 libwind0
-heimdal libx11-data libxau6 libxml2 libxmlsec1 libxslt1.1 libyaml-0-2 linux-libc-dev lxcfs lxd-client manpages-dev pinentry-curses publicsuffix python-apt-common
  squashfs
-tools uidmap vim-runtime xdelta3 xdg-user-dirs zerofree
Use 'sudo apt autoremove' to remove them.
Suggested packages:
  glibc
-doc locales
The following packages will be REMOVED:
  accountsservice adduser apparmor apport apt apt
-clone apt-utils at bcache-tools bind9-host binutils binutils-x86-64-linux-gnu bsdmainutils bsdutils btrfs-progs btrfs-tools build-essential
  byobu ca
-certificates cifs-utils cloud-guest-utils cloud-init cloud-initramfs-copymods cloud-initramfs-dyn-netconf command-not-found coreutils crda cron cryptsetup cryptsetup-bin curl dbus
  dirmngr dkms dmeventd dmsetup dnsmasq
-base dnsutils dosfstools dpkg-dev e2fsprogs efibootmgr eject fdisk friendly-recovery fuse g++ g++-7 gcc gcc-7 gdisk gir1.2-glib-2.0 git git-core gnupg
  gpg
-wks-client init initramfs-tools initramfs-tools-bin initramfs-tools-core iproute2 irqbalance isc-dhcp-client landscape-common language-selector-common libaccountsservice0
  libapt
-inst2.0 libapt-pkg5.0 libavahi-client3 libbind9-160 libblkid1 libbsd0 libc-bin libc-dev-bin libc6-dev libcryptsetup12 libcups2 libcurl3-gnutls libcurl4 libdbus-1-3
  libdevmapper
-event1.02.1 libdevmapper1.02.1 libdns-export1100 libdns1100 libexpat1 libfdisk1 libgirepository-1.0-1 libglib2.0-0 libgnutls30 libgssapi-krb5-2 libirs160 libisc-export169
  libisc169 libisccc160 libisccfg160 libisns0 libldap
-2.4-2 libldb1 liblvm2app2.2 liblvm2cmd2.02 liblxc-common liblxc1 libmount1 libnetplan0 libnss-systemd libp11-kit0 libpam-cap
  libpam
-modules libpam-runtime libpam-systemd libparted2 libpci3 libpolkit-agent-1-0 libpolkit-backend-1-0 libpolkit-gobject-1-0 libpopt0 libprocps6 libpython-stdlib libpython2.7
  libpython2
.7-stdlib libpython3-stdlib libpython3.6 libpython3.6-minimal libpython3.6-stdlib librtmp1 libsasl2-modules libsmartcols1 libssl1.1 libstdc++-7-dev libsystemd0 libudev1
  libusb
-1.0-0 libuuid1 libwbclient0 libx11-6 libxcb1 libxdmcp6 libxext6 libxmlsec1-openssl libxmuu1 linux-azure linux-azure-5.3-headers-5.3.0-1032 linux-azure-5.3-tools-5.3.0-1032
  linux
-headers-5.3.0-1032-azure linux-headers-azure linux-image-azure linux-modules-extra-5.3.0-1032-azure linux-tools-5.3.0-1032-azure linux-tools-azure linux-tools-common locales login
  logrotate lsb
-release lshw lvm2 lxd make man-db mdadm microsoft-dependency-agent-dkms mlocate mokutil mount netcat-openbsd netplan.io networkd-dispatcher nplan ntfs-3g omi omsagent
  omsconfig open
-iscsi open-vm-tools openssh-client openssh-server openssh-sftp-server openssl overlayroot parted passwd pastebinit pciutils policykit-1 pollinate procps python python-crypto
  python
-ldb python-samba python-talloc python-tdb python2.7 python3 python3-apport python3-apt python3-asn1crypto python3-attr python3-automat python3-blinker python3-certifi
  python3
-cffi-backend python3-chardet python3-click python3-colorama python3-commandnotfound python3-configobj python3-constantly python3-cryptography python3-dbus python3-debconf
  python3
-debian python3-distro-info python3-distupgrade python3-gdbm python3-gi python3-httplib2 python3-hyperlink python3-idna python3-incremental python3-jinja2 python3-json-pointer
  python3
-jsonpatch python3-jsonschema python3-jwt python3-markupsafe python3-minimal python3-netifaces python3-newt python3-oauthlib python3-openssl python3-pam python3-pkg-resources
  python3
-problem-report python3-pyasn1 python3-pyasn1-modules python3-requests python3-requests-unixsocket python3-serial python3-service-identity python3-six python3-software-properties
  python3
-systemd python3-twisted python3-twisted-bin python3-update-manager python3-urllib3 python3-yaml python3-zope.interface python3.6 python3.6-minimal rsync rsyslog run-one
  samba
-common samba-common-bin samba-libs sbsigntool scx secureboot-db shared-mime-info snapd software-properties-common sosreport ssh-import-id sudo systemd systemd-sysv sysvinit-utils
  tcpdump tmux ubuntu
-minimal ubuntu-release-upgrader-core ubuntu-server ubuntu-standard ucf udev ufw unattended-upgrades update-manager-core update-notifier-common ureadahead usbutils
  util
-linux uuid-runtime vim walinuxagent wget whiptail xauth xfsprogs
The following packages will be DOWNGRADED:
  libc6
WARNING
: The following essential packages will be removed.
This should NOT be done unless you know exactly what you are doing!
  apt adduser
(due to apt) libapt-pkg5.0 (due to apt) libgnutls30 (due to apt) bsdutils libsystemd0 (due to bsdutils) coreutils e2fsprogs libblkid1 (due to e2fsprogs)
  libuuid1
(due to e2fsprogs) fdisk libfdisk1 (due to fdisk) libmount1 (due to fdisk) libsmartcols1 (due to fdisk) init systemd-sysv (due to init) libc-bin login
  libpam
-runtime (due to login) libpam-modules (due to login) mount util-linux (due to mount) sysvinit-utils libudev1 (due to util-linux)
0 upgraded, 0 newly installed, 1 downgraded, 291 to remove and 0 not upgraded.
Need to get 2584 kB of archives.
After this operation, 839 MB disk space will be freed.
You are about to do something potentially harmful.
To continue type in the phrase 'Yes, do as I say!'
 
?] ^C


@Vladimir, Thank you...
I'll check with docker solution if I'm not able to figure out otherwise... For now I would like to run the build directly, as otherwise I'll have to modify CI/CD integration as well :)



On Saturday, August 1, 2020 at 6:34:37 PM UTC+2, Kushtrim Pacaj wrote:

I am trying to setup a new build server for AOSP and ran into problems setting up the environment.
I've done this lots of times without problems, but something seems to have changed.

This is a fresh install of Ubuntu 18.04.4 LTS.
What I'm trying to install is this ( from this link <a href="https://source.android.com/setup/build/initializing" style="font-family:Arial,Helvetica,sans-serif;font-size:13px" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://source.android.com/setup/build/initializing&#39;;return true;" onclick="this.href=&#39;https://source.android.com/setup/build/initializing&#39;;return true;">https://source.android.com/setup/build/initializing )


sudo apt-get install git-core gnupg flex bison build-essential zip curl zlib1g-dev gcc-multilib g++-multilib libc6-dev-i386 lib32ncurses5-dev x11proto-core-dev libx11-dev lib32z1-dev libgl1-mesa-dev libxml2-utils xsltproc unzip fontconfig


This is the output:  

Building dependency tree      

Reading state information... Done

fontconfig is already the newest version (2.11.94-0ubuntu1.1).

fontconfig set to manually installed.

curl is already the newest version (7.58.0-2ubuntu3.9).

curl set to manually installed.

build-essential is already the newest version (12.4ubuntu1).

build-essential set to manually installed.

gnupg is already the newest version (2.2.4-1ubuntu1.2).

gnupg set to manually installed.

Some packages could not be installed. This may mean that you have

requested an impossible situation or if you are using the unstable

distribution that some required packages have not yet been created

or been moved out of Incoming.

The following information may help to resolve the situation:


The following packages have unmet dependencies:

g++-multilib : Depends: g++-5-multilib (>= 5.3.1-3~) but it is not going to be installed

gcc-multilib : Depends: gcc-5-multilib (>= 5.3.1-3~) but it is not going to be installed

lib32ncurses5-dev : Depends: lib32tinfo5 (= 6.0+20160213-1ubuntu1) but it is not going to be installed

                    Depends: lib32ncurses5 (= 6.0+20160213-1ubuntu1) but it is not going to be installed

                    Depends: lib32tinfo-dev (= 6.0+20160213-1ubuntu1) but it is not going to be installed

                    Depends: libncurses5-dev (= 6.0+20160213-1ubuntu1) but it is not going to be installed

lib32z1-dev : Depends: lib32z1 (= 1:1.2.8.dfsg-2ubuntu4.3) but it is not going to be installed

libc6-dev-i386 : Depends: libc6-i386 (= 2.23-0ubuntu11.2) but it is not going to be installed

                 Depends: libc6-dev (= 2.23-0ubuntu11.2) but 2.27-3ubuntu1.2 is to be installed

libgl1-mesa-dev : Depends: mesa-common-dev (= 18.0.5-0ubuntu0~16.04.1) but it is not going to be installed

                  Depends: libdrm-dev (>= 2.4.74) but it is not going to be installed

                  Depends: libx11-xcb-dev but it is not going to be installed

                  Depends: libxcb-dri3-dev but it is not going to be installed

                  Depends: libxcb-present-dev but it is not going to be installed

                  Depends: libxcb-sync-dev but it is not going to be installed

                  Depends: libxcb-dri2-0-dev but it is not going to be installed

                  Depends: libxcb-glx0-dev but it is not going to be installed

libx11-dev : Depends: libx11-6 (= 2:1.6.3-1ubuntu2.1) but 2:1.6.4-3ubuntu0.2 is to be installed

             Depends: libxau-dev (>= 1:1.0.0-1) but it is not going to be installed

             Depends: libxdmcp-dev (>= 1:1.0.0-1) but it is not going to be installed

             Depends: libxcb1-dev but it is not going to be installed

             Recommends: libx11-doc but it is not going to be installed

zlib1g-dev : Depends: zlib1g (= 1:1.2.8.dfsg-2ubuntu4.3) but 1:1.2.11.dfsg-0ubuntu2 is to be installed

E: Unable to correct problems, you have held broken packages.



--
--
You received this message because you are subscribed to the "Android Building" mailing list.
To post to this group, send email to [hidden email]
To unsubscribe from this group, send email to
[hidden email]
For more options, visit this group at
http://groups.google.com/group/android-building?hl=en

---
You received this message because you are subscribed to the Google Groups "Android Building" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/android-building/21829b59-d70c-4bfc-913c-dcef504fceb6o%40googlegroups.com.
Reply | Threaded
Open this post in threaded view
|

Re: Cannot setup build environment in Ubuntu 18.04

Sooraj Sizon
Few things you can try at this point ,

1) update source list and run upgrade
 sudo apt-get update
 sudo apt
-get upgrade


2)
I don't know why this is necessary, but manually installing the problematic packages works sometimes.
sudo apt-get install <missing-package-1> <missing-package-2> ...

3)
Its possible you have a mixed /etc/apt/sources.list? It appears that you're trying to install one package from a newer repository but that it doesn't have access to a repository with the newer dependencies.

sudo dpkg -r <conflicting_package> (to remove wrong version)
sudo apt
-get install <package>



On Monday, August 3, 2020 at 2:19:03 AM UTC+5:30, Kushtrim Pacaj wrote:
@Sooraj, thank you for you reponse:

I downgraded zlib1g, and the error for that package seems to have gone away, but I cannot seem to do the same for others.... Especially libc6, as that seems to provide a warning that it will delete core stuff:


The following packages have unmet dependencies:
 g
++-multilib : Depends: g++-5-multilib (>= 5.3.1-3~) but it is not going to be installed
 gcc
-multilib : Depends: gcc-5-multilib (>= 5.3.1-3~) but it is not going to be installed
 lib32ncurses5
-dev : Depends: lib32tinfo5 (= 6.0+20160213-1ubuntu1) but it is not going to be installed
                     
Depends: lib32ncurses5 (= 6.0+20160213-1ubuntu1) but it is not going to be installed
                     
Depends: lib32tinfo-dev (= 6.0+20160213-1ubuntu1) but it is not going to be installed
                     
Depends: libncurses5-dev (= 6.0+20160213-1ubuntu1) but it is not going to be installed
 lib32z1
-dev : Depends: lib32z1 (= 1:1.2.8.dfsg-2ubuntu4.3) but it is not going to be installed
 libc6
-dev-i386 : Depends: libc6-i386 (= 2.23-0ubuntu11.2) but it is not going to be installed
                 
Depends: libc6-dev (= 2.23-0ubuntu11.2) but 2.27-3ubuntu1.2 is to be installed
 libgl1
-mesa-dev : Depends: mesa-common-dev (= 18.0.5-0ubuntu0~16.04.1) but it is not going to be installed
                   
Depends: libdrm-dev (>= 2.4.74) but it is not going to be installed
                   
Depends: libx11-xcb-dev but it is not going to be installed
                   
Depends: libxcb-dri3-dev but it is not going to be installed
                   
Depends: libxcb-present-dev but it is not going to be installed
                   
Depends: libxcb-sync-dev but it is not going to be installed
                   
Depends: libxcb-dri2-0-dev but it is not going to be installed
                   
Depends: libxcb-glx0-dev but it is not going to be installed
 libx11
-dev : Depends: libxau-dev (>= 1:1.0.0-1) but it is not going to be installed
             
Depends: libxdmcp-dev (>= 1:1.0.0-1) but it is not going to be installed
             
Depends: libxcb1-dev but it is not going to be installed
E
: Unable to correct problems, you have held broken packages.
username@build
-agent08:~$ sudo apt-get insall libxau-dev=1:1.0.0-1
E
: Invalid operation insall
username@build
-agent08:~$ sudo apt-get install libxau-dev=1:1.0.0-1
Reading package lists... Done
Building dependency tree      
Reading state information... Done
E
: Version '1:1.0.0-1' for 'libxau-dev' was not found
username@build
-agent08:~$ sudo apt-get install ibxdmcp-dev=1:1.0.0-1
Reading package lists... Done
Building dependency tree      
Reading state information... Done
E
: Unable to locate package ibxdmcp-dev
username@build
-agent08:~$ sudo apt-get install libxdmcp-dev=1:1.0.0-1
Reading package lists... Done
Building dependency tree      
Reading state information... Done
E
: Version '1:1.0.0-1' for 'libxdmcp-dev' was not found
username@build
-agent08:~$ sudo apt-get install lib32tinfo5=6.0+20160213-1ubuntu1
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation
or if you are using the unstable
distribution that some required packages have
not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:


The following packages have unmet dependencies:
 lib32tinfo5
: Depends: libc6-i386 (>= 2.16) but it is not going to be installed
E
: Unable to correct problems, you have held broken packages.
username@build
-agent08:~$ sudo apt-get install libc6-i386=2.23-0ubuntu11.2
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation
or if you are using the unstable
distribution that some required packages have
not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:


The following packages have unmet dependencies:
 libc6
-i386 : Depends: libc6 (= 2.23-0ubuntu11.2) but 2.27-3ubuntu1.2 is to be installed
E
: Unable to correct problems, you have held broken packages.
username@build
-agent08:~$ sudo apt-get install libc6=2.23-0ubuntu11.2
Reading package lists... Done
Building dependency tree      
Reading state information... Done
The following packages were automatically installed and are no longer required:
  acl apport
-symptoms bc binutils-common busybox-initramfs command-not-found-data cpp cpp-7 distro-info-data dns-root-data dpkg-repack ebtables fakeroot geoip-database gettext-base git-man
  gnupg
-l10n gnupg-utils gpg gpg-agent gpg-wks-server gpgconf gpgsm gpgv groff-base isc-dhcp-common iso-codes klibc-utils krb5-locales libalgorithm-diff-perl libalgorithm-diff-xs-perl
  libalgorithm
-merge-perl libapparmor1 libargon2-0 libasan4 libasn1-8-heimdal libassuan0 libatm1 libatomic1 libbinutils libcc1-0 libcilkrts5 libdpkg-perl libdrm-common libdrm2 libedit2
  liberror
-perl libestr0 libevent-2.1-6 libfakeroot libfastjson4 libffi6 libfile-fcntllock-perl libfribidi0 libfuse2 libgcc-7-dev libgeoip1 libglib2.0-data libgomp1 libgssapi3-heimdal
  libhcrypto4
-heimdal libheimbase1-heimdal libheimntlm0-heimdal libhogweed4 libhx509-5-heimdal libicu60 libidn2-0 libisl19 libitm1 libjson-c3 libk5crypto3 libklibc libkrb5-26-heimdal
  libkrb5
-3 libkrb5support0 libksba8 libldap-common liblsan0 liblwres160 liblzo2-2 libmpc3 libmpdec2 libmpx2 libmspack0 libnewt0.52 libnghttp2-14 libnpth0 libntfs-3g88 libnuma1 libpcap0.8
  libpipeline1 libpsl5 libquadmath0 libreadline5 libroken18
-heimdal libsasl2-2 libsasl2-modules-db libseccomp2 libslang2 libsqlite3-0 libssl1.0.0 libtasn1-6 libtsan0 libubsan0 libunistring2
  libuv1 libwind0
-heimdal libx11-data libxau6 libxml2 libxmlsec1 libxslt1.1 libyaml-0-2 linux-libc-dev lxcfs lxd-client manpages-dev pinentry-curses publicsuffix python-apt-common
  squashfs
-tools uidmap vim-runtime xdelta3 xdg-user-dirs zerofree
Use 'sudo apt autoremove' to remove them.
Suggested packages:
  glibc
-doc locales
The following packages will be REMOVED:
  accountsservice adduser apparmor apport apt apt
-clone apt-utils at bcache-tools bind9-host binutils binutils-x86-64-linux-gnu bsdmainutils bsdutils btrfs-progs btrfs-tools build-essential
  byobu ca
-certificates cifs-utils cloud-guest-utils cloud-init cloud-initramfs-copymods cloud-initramfs-dyn-netconf command-not-found coreutils crda cron cryptsetup cryptsetup-bin curl dbus
  dirmngr dkms dmeventd dmsetup dnsmasq
-base dnsutils dosfstools dpkg-dev e2fsprogs efibootmgr eject fdisk friendly-recovery fuse g++ g++-7 gcc gcc-7 gdisk gir1.2-glib-2.0 git git-core gnupg
  gpg
-wks-client init initramfs-tools initramfs-tools-bin initramfs-tools-core iproute2 irqbalance isc-dhcp-client landscape-common language-selector-common libaccountsservice0
  libapt
-inst2.0 libapt-pkg5.0 libavahi-client3 libbind9-160 libblkid1 libbsd0 libc-bin libc-dev-bin libc6-dev libcryptsetup12 libcups2 libcurl3-gnutls libcurl4 libdbus-1-3
  libdevmapper
-event1.02.1 libdevmapper1.02.1 libdns-export1100 libdns1100 libexpat1 libfdisk1 libgirepository-1.0-1 libglib2.0-0 libgnutls30 libgssapi-krb5-2 libirs160 libisc-export169
  libisc169 libisccc160 libisccfg160 libisns0 libldap
-2.4-2 libldb1 liblvm2app2.2 liblvm2cmd2.02 liblxc-common liblxc1 libmount1 libnetplan0 libnss-systemd libp11-kit0 libpam-cap
  libpam
-modules libpam-runtime libpam-systemd libparted2 libpci3 libpolkit-agent-1-0 libpolkit-backend-1-0 libpolkit-gobject-1-0 libpopt0 libprocps6 libpython-stdlib libpython2.7
  libpython2
.7-stdlib libpython3-stdlib libpython3.6 libpython3.6-minimal libpython3.6-stdlib librtmp1 libsasl2-modules libsmartcols1 libssl1.1 libstdc++-7-dev libsystemd0 libudev1
  libusb
-1.0-0 libuuid1 libwbclient0 libx11-6 libxcb1 libxdmcp6 libxext6 libxmlsec1-openssl libxmuu1 linux-azure linux-azure-5.3-headers-5.3.0-1032 linux-azure-5.3-tools-5.3.0-1032
  linux
-headers-5.3.0-1032-azure linux-headers-azure linux-image-azure linux-modules-extra-5.3.0-1032-azure linux-tools-5.3.0-1032-azure linux-tools-azure linux-tools-common locales login
  logrotate lsb
-release lshw lvm2 lxd make man-db mdadm microsoft-dependency-agent-dkms mlocate mokutil mount netcat-openbsd netplan.io networkd-dispatcher nplan ntfs-3g omi omsagent
  omsconfig open
-iscsi open-vm-tools openssh-client openssh-server openssh-sftp-server openssl overlayroot parted passwd pastebinit pciutils policykit-1 pollinate procps python python-crypto
  python
-ldb python-samba python-talloc python-tdb python2.7 python3 python3-apport python3-apt python3-asn1crypto python3-attr python3-automat python3-blinker python3-certifi
  python3
-cffi-backend python3-chardet python3-click python3-colorama python3-commandnotfound python3-configobj python3-constantly python3-cryptography python3-dbus python3-debconf
  python3
-debian python3-distro-info python3-distupgrade python3-gdbm python3-gi python3-httplib2 python3-hyperlink python3-idna python3-incremental python3-jinja2 python3-json-pointer
  python3
-jsonpatch python3-jsonschema python3-jwt python3-markupsafe python3-minimal python3-netifaces python3-newt python3-oauthlib python3-openssl python3-pam python3-pkg-resources
  python3
-problem-report python3-pyasn1 python3-pyasn1-modules python3-requests python3-requests-unixsocket python3-serial python3-service-identity python3-six python3-software-properties
  python3
-systemd python3-twisted python3-twisted-bin python3-update-manager python3-urllib3 python3-yaml python3-zope.interface python3.6 python3.6-minimal rsync rsyslog run-one
  samba
-common samba-common-bin samba-libs sbsigntool scx secureboot-db shared-mime-info snapd software-properties-common sosreport ssh-import-id sudo systemd systemd-sysv sysvinit-utils
  tcpdump tmux ubuntu
-minimal ubuntu-release-upgrader-core ubuntu-server ubuntu-standard ucf udev ufw unattended-upgrades update-manager-core update-notifier-common ureadahead usbutils
  util
-linux uuid-runtime vim walinuxagent wget whiptail xauth xfsprogs
The following packages will be DOWNGRADED:
  libc6
WARNING
: The following essential packages will be removed.
This should NOT be done unless you know exactly what you are doing!
  apt adduser
(due to apt) libapt-pkg5.0 (due to apt) libgnutls30 (due to apt) bsdutils libsystemd0 (due to bsdutils) coreutils e2fsprogs libblkid1 (due to e2fsprogs)
  libuuid1
(due to e2fsprogs) fdisk libfdisk1 (due to fdisk) libmount1 (due to fdisk) libsmartcols1 (due to fdisk) init systemd-sysv (due to init) libc-bin login
  libpam
-runtime (due to login) libpam-modules (due to login) mount util-linux (due to mount) sysvinit-utils libudev1 (due to util-linux)
0 upgraded, 0 newly installed, 1 downgraded, 291 to remove and 0 not upgraded.
Need to get 2584 kB of archives.
After this operation, 839 MB disk space will be freed.
You are about to do something potentially harmful.
To continue type in the phrase 'Yes, do as I say!'
 
?] ^C


@Vladimir, Thank you...
I'll check with docker solution if I'm not able to figure out otherwise... For now I would like to run the build directly, as otherwise I'll have to modify CI/CD integration as well :)



On Saturday, August 1, 2020 at 6:34:37 PM UTC+2, Kushtrim Pacaj wrote:

I am trying to setup a new build server for AOSP and ran into problems setting up the environment.
I've done this lots of times without problems, but something seems to have changed.

This is a fresh install of Ubuntu 18.04.4 LTS.
What I'm trying to install is this ( from this link <a href="https://source.android.com/setup/build/initializing" style="font-family:Arial,Helvetica,sans-serif;font-size:13px" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://source.android.com/setup/build/initializing&#39;;return true;" onclick="this.href=&#39;https://source.android.com/setup/build/initializing&#39;;return true;">https://source.android.com/setup/build/initializing )


sudo apt-get install git-core gnupg flex bison build-essential zip curl zlib1g-dev gcc-multilib g++-multilib libc6-dev-i386 lib32ncurses5-dev x11proto-core-dev libx11-dev lib32z1-dev libgl1-mesa-dev libxml2-utils xsltproc unzip fontconfig


This is the output:  

Building dependency tree      

Reading state information... Done

fontconfig is already the newest version (2.11.94-0ubuntu1.1).

fontconfig set to manually installed.

curl is already the newest version (7.58.0-2ubuntu3.9).

curl set to manually installed.

build-essential is already the newest version (12.4ubuntu1).

build-essential set to manually installed.

gnupg is already the newest version (2.2.4-1ubuntu1.2).

gnupg set to manually installed.

Some packages could not be installed. This may mean that you have

requested an impossible situation or if you are using the unstable

distribution that some required packages have not yet been created

or been moved out of Incoming.

The following information may help to resolve the situation:


The following packages have unmet dependencies:

g++-multilib : Depends: g++-5-multilib (>= 5.3.1-3~) but it is not going to be installed

gcc-multilib : Depends: gcc-5-multilib (>= 5.3.1-3~) but it is not going to be installed

lib32ncurses5-dev : Depends: lib32tinfo5 (= 6.0+20160213-1ubuntu1) but it is not going to be installed

                    Depends: lib32ncurses5 (= 6.0+20160213-1ubuntu1) but it is not going to be installed

                    Depends: lib32tinfo-dev (= 6.0+20160213-1ubuntu1) but it is not going to be installed

                    Depends: libncurses5-dev (= 6.0+20160213-1ubuntu1) but it is not going to be installed

lib32z1-dev : Depends: lib32z1 (= 1:1.2.8.dfsg-2ubuntu4.3) but it is not going to be installed

libc6-dev-i386 : Depends: libc6-i386 (= 2.23-0ubuntu11.2) but it is not going to be installed

                 Depends: libc6-dev (= 2.23-0ubuntu11.2) but 2.27-3ubuntu1.2 is to be installed

libgl1-mesa-dev : Depends: mesa-common-dev (= 18.0.5-0ubuntu0~16.04.1) but it is not going to be installed

                  Depends: libdrm-dev (>= 2.4.74) but it is not going to be installed

                  Depends: libx11-xcb-dev but it is not going to be installed

                  Depends: libxcb-dri3-dev but it is not going to be installed

                  Depends: libxcb-present-dev but it is not going to be installed

                  Depends: libxcb-sync-dev but it is not going to be installed

                  Depends: libxcb-dri2-0-dev but it is not going to be installed

                  Depends: libxcb-glx0-dev but it is not going to be installed

libx11-dev : Depends: libx11-6 (= 2:1.6.3-1ubuntu2.1) but 2:1.6.4-3ubuntu0.2 is to be installed

             Depends: libxau-dev (>= 1:1.0.0-1) but it is not going to be installed

             Depends: libxdmcp-dev (>= 1:1.0.0-1) but it is not going to be installed

             Depends: libxcb1-dev but it is not going to be installed

             Recommends: libx11-doc but it is not going to be installed

zlib1g-dev : Depends: zlib1g (= 1:1.2.8.dfsg-2ubuntu4.3) but 1:1.2.11.dfsg-0ubuntu2 is to be installed

E: Unable to correct problems, you have held broken packages.



--
--
You received this message because you are subscribed to the "Android Building" mailing list.
To post to this group, send email to [hidden email]
To unsubscribe from this group, send email to
[hidden email]
For more options, visit this group at
http://groups.google.com/group/android-building?hl=en

---
You received this message because you are subscribed to the Google Groups "Android Building" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/android-building/5c8024ec-85af-4e9c-b04d-5d843c110f81o%40googlegroups.com.
Reply | Threaded
Open this post in threaded view
|

Re: Cannot setup build environment in Ubuntu 18.04

Kushtrim Pacaj
Upgraded the server to 20.04, and managed to install without problems :)

On Monday, August 3, 2020 at 4:21:00 PM UTC+2 [hidden email] wrote:
Few things you can try at this point ,

1) update source list and run upgrade
 sudo apt-get update
 sudo apt
-get upgrade


2)
I don't know why this is necessary, but manually installing the problematic packages works sometimes.
sudo apt-get install <missing-package-1> <missing-package-2> ...

3)
Its possible you have a mixed /etc/apt/sources.list? It appears that you're trying to install one package from a newer repository but that it doesn't have access to a repository with the newer dependencies.

sudo dpkg -r <conflicting_package> (to remove wrong version)
sudo apt
-get install <package>



On Monday, August 3, 2020 at 2:19:03 AM UTC+5:30, Kushtrim Pacaj wrote:
@Sooraj, thank you for you reponse:

I downgraded zlib1g, and the error for that package seems to have gone away, but I cannot seem to do the same for others.... Especially libc6, as that seems to provide a warning that it will delete core stuff:


The following packages have unmet dependencies:
 g
++-multilib : Depends: g++-5-multilib (>= 5.3.1-3~) but it is not going to be installed
 gcc
-multilib : Depends: gcc-5-multilib (>= 5.3.1-3~) but it is not going to be installed
 lib32ncurses5
-dev : Depends: lib32tinfo5 (= 6.0+20160213-1ubuntu1) but it is not going to be installed
                     
Depends: lib32ncurses5 (= 6.0+20160213-1ubuntu1) but it is not going to be installed
                     
Depends: lib32tinfo-dev (= 6.0+20160213-1ubuntu1) but it is not going to be installed
                     
Depends: libncurses5-dev (= 6.0+20160213-1ubuntu1) but it is not going to be installed
 lib32z1
-dev : Depends: lib32z1 (= 1:1.2.8.dfsg-2ubuntu4.3) but it is not going to be installed
 libc6
-dev-i386 : Depends: libc6-i386 (= 2.23-0ubuntu11.2) but it is not going to be installed
                 
Depends: libc6-dev (= 2.23-0ubuntu11.2) but 2.27-3ubuntu1.2 is to be installed
 libgl1
-mesa-dev : Depends: mesa-common-dev (= 18.0.5-0ubuntu0~16.04.1) but it is not going to be installed
                   
Depends: libdrm-dev (>= 2.4.74) but it is not going to be installed
                   
Depends: libx11-xcb-dev but it is not going to be installed
                   
Depends: libxcb-dri3-dev but it is not going to be installed
                   
Depends: libxcb-present-dev but it is not going to be installed
                   
Depends: libxcb-sync-dev but it is not going to be installed
                   
Depends: libxcb-dri2-0-dev but it is not going to be installed
                   
Depends: libxcb-glx0-dev but it is not going to be installed
 libx11
-dev : Depends: libxau-dev (>= 1:1.0.0-1) but it is not going to be installed
             
Depends: libxdmcp-dev (>= 1:1.0.0-1) but it is not going to be installed
             
Depends: libxcb1-dev but it is not going to be installed
E
: Unable to correct problems, you have held broken packages.
username@build
-agent08:~$ sudo apt-get insall libxau-dev=1:1.0.0-1
E
: Invalid operation insall
username@build
-agent08:~$ sudo apt-get install libxau-dev=1:1.0.0-1
Reading package lists... Done
Building dependency tree      
Reading state information... Done
E
: Version '1:1.0.0-1' for 'libxau-dev' was not found
username@build
-agent08:~$ sudo apt-get install ibxdmcp-dev=1:1.0.0-1
Reading package lists... Done
Building dependency tree      
Reading state information... Done
E
: Unable to locate package ibxdmcp-dev
username@build
-agent08:~$ sudo apt-get install libxdmcp-dev=1:1.0.0-1
Reading package lists... Done
Building dependency tree      
Reading state information... Done
E
: Version '1:1.0.0-1' for 'libxdmcp-dev' was not found
username@build
-agent08:~$ sudo apt-get install lib32tinfo5=6.0+20160213-1ubuntu1
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation
or if you are using the unstable
distribution that some required packages have
not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:


The following packages have unmet dependencies:
 lib32tinfo5
: Depends: libc6-i386 (>= 2.16) but it is not going to be installed
E
: Unable to correct problems, you have held broken packages.
username@build
-agent08:~$ sudo apt-get install libc6-i386=2.23-0ubuntu11.2
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation
or if you are using the unstable
distribution that some required packages have
not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:


The following packages have unmet dependencies:
 libc6
-i386 : Depends: libc6 (= 2.23-0ubuntu11.2) but 2.27-3ubuntu1.2 is to be installed
E
: Unable to correct problems, you have held broken packages.
username@build
-agent08:~$ sudo apt-get install libc6=2.23-0ubuntu11.2
Reading package lists... Done
Building dependency tree      
Reading state information... Done
The following packages were automatically installed and are no longer required:
  acl apport
-symptoms bc binutils-common busybox-initramfs command-not-found-data cpp cpp-7 distro-info-data dns-root-data dpkg-repack ebtables fakeroot geoip-database gettext-base git-man
  gnupg
-l10n gnupg-utils gpg gpg-agent gpg-wks-server gpgconf gpgsm gpgv groff-base isc-dhcp-common iso-codes klibc-utils krb5-locales libalgorithm-diff-perl libalgorithm-diff-xs-perl
  libalgorithm
-merge-perl libapparmor1 libargon2-0 libasan4 libasn1-8-heimdal libassuan0 libatm1 libatomic1 libbinutils libcc1-0 libcilkrts5 libdpkg-perl libdrm-common libdrm2 libedit2
  liberror
-perl libestr0 libevent-2.1-6 libfakeroot libfastjson4 libffi6 libfile-fcntllock-perl libfribidi0 libfuse2 libgcc-7-dev libgeoip1 libglib2.0-data libgomp1 libgssapi3-heimdal
  libhcrypto4
-heimdal libheimbase1-heimdal libheimntlm0-heimdal libhogweed4 libhx509-5-heimdal libicu60 libidn2-0 libisl19 libitm1 libjson-c3 libk5crypto3 libklibc libkrb5-26-heimdal
  libkrb5
-3 libkrb5support0 libksba8 libldap-common liblsan0 liblwres160 liblzo2-2 libmpc3 libmpdec2 libmpx2 libmspack0 libnewt0.52 libnghttp2-14 libnpth0 libntfs-3g88 libnuma1 libpcap0.8
  libpipeline1 libpsl5 libquadmath0 libreadline5 libroken18
-heimdal libsasl2-2 libsasl2-modules-db libseccomp2 libslang2 libsqlite3-0 libssl1.0.0 libtasn1-6 libtsan0 libubsan0 libunistring2
  libuv1 libwind0
-heimdal libx11-data libxau6 libxml2 libxmlsec1 libxslt1.1 libyaml-0-2 linux-libc-dev lxcfs lxd-client manpages-dev pinentry-curses publicsuffix python-apt-common
  squashfs
-tools uidmap vim-runtime xdelta3 xdg-user-dirs zerofree
Use 'sudo apt autoremove' to remove them.
Suggested packages:
  glibc
-doc locales
The following packages will be REMOVED:
  accountsservice adduser apparmor apport apt apt
-clone apt-utils at bcache-tools bind9-host binutils binutils-x86-64-linux-gnu bsdmainutils bsdutils btrfs-progs btrfs-tools build-essential
  byobu ca
-certificates cifs-utils cloud-guest-utils cloud-init cloud-initramfs-copymods cloud-initramfs-dyn-netconf command-not-found coreutils crda cron cryptsetup cryptsetup-bin curl dbus
  dirmngr dkms dmeventd dmsetup dnsmasq
-base dnsutils dosfstools dpkg-dev e2fsprogs efibootmgr eject fdisk friendly-recovery fuse g++ g++-7 gcc gcc-7 gdisk gir1.2-glib-2.0 git git-core gnupg
  gpg
-wks-client init initramfs-tools initramfs-tools-bin initramfs-tools-core iproute2 irqbalance isc-dhcp-client landscape-common language-selector-common libaccountsservice0
  libapt
-inst2.0 libapt-pkg5.0 libavahi-client3 libbind9-160 libblkid1 libbsd0 libc-bin libc-dev-bin libc6-dev libcryptsetup12 libcups2 libcurl3-gnutls libcurl4 libdbus-1-3
  libdevmapper
-event1.02.1 libdevmapper1.02.1 libdns-export1100 libdns1100 libexpat1 libfdisk1 libgirepository-1.0-1 libglib2.0-0 libgnutls30 libgssapi-krb5-2 libirs160 libisc-export169
  libisc169 libisccc160 libisccfg160 libisns0 libldap
-2.4-2 libldb1 liblvm2app2.2 liblvm2cmd2.02 liblxc-common liblxc1 libmount1 libnetplan0 libnss-systemd libp11-kit0 libpam-cap
  libpam
-modules libpam-runtime libpam-systemd libparted2 libpci3 libpolkit-agent-1-0 libpolkit-backend-1-0 libpolkit-gobject-1-0 libpopt0 libprocps6 libpython-stdlib libpython2.7
  libpython2
.7-stdlib libpython3-stdlib libpython3.6 libpython3.6-minimal libpython3.6-stdlib librtmp1 libsasl2-modules libsmartcols1 libssl1.1 libstdc++-7-dev libsystemd0 libudev1
  libusb
-1.0-0 libuuid1 libwbclient0 libx11-6 libxcb1 libxdmcp6 libxext6 libxmlsec1-openssl libxmuu1 linux-azure linux-azure-5.3-headers-5.3.0-1032 linux-azure-5.3-tools-5.3.0-1032
  linux
-headers-5.3.0-1032-azure linux-headers-azure linux-image-azure linux-modules-extra-5.3.0-1032-azure linux-tools-5.3.0-1032-azure linux-tools-azure linux-tools-common locales login
  logrotate lsb
-release lshw lvm2 lxd make man-db mdadm microsoft-dependency-agent-dkms mlocate mokutil mount netcat-openbsd netplan.io networkd-dispatcher nplan ntfs-3g omi omsagent
  omsconfig open
-iscsi open-vm-tools openssh-client openssh-server openssh-sftp-server openssl overlayroot parted passwd pastebinit pciutils policykit-1 pollinate procps python python-crypto
  python
-ldb python-samba python-talloc python-tdb python2.7 python3 python3-apport python3-apt python3-asn1crypto python3-attr python3-automat python3-blinker python3-certifi
  python3
-cffi-backend python3-chardet python3-click python3-colorama python3-commandnotfound python3-configobj python3-constantly python3-cryptography python3-dbus python3-debconf
  python3
-debian python3-distro-info python3-distupgrade python3-gdbm python3-gi python3-httplib2 python3-hyperlink python3-idna python3-incremental python3-jinja2 python3-json-pointer
  python3
-jsonpatch python3-jsonschema python3-jwt python3-markupsafe python3-minimal python3-netifaces python3-newt python3-oauthlib python3-openssl python3-pam python3-pkg-resources
  python3
-problem-report python3-pyasn1 python3-pyasn1-modules python3-requests python3-requests-unixsocket python3-serial python3-service-identity python3-six python3-software-properties
  python3
-systemd python3-twisted python3-twisted-bin python3-update-manager python3-urllib3 python3-yaml python3-zope.interface python3.6 python3.6-minimal rsync rsyslog run-one
  samba
-common samba-common-bin samba-libs sbsigntool scx secureboot-db shared-mime-info snapd software-properties-common sosreport ssh-import-id sudo systemd systemd-sysv sysvinit-utils
  tcpdump tmux ubuntu
-minimal ubuntu-release-upgrader-core ubuntu-server ubuntu-standard ucf udev ufw unattended-upgrades update-manager-core update-notifier-common ureadahead usbutils
  util
-linux uuid-runtime vim walinuxagent wget whiptail xauth xfsprogs
The following packages will be DOWNGRADED:
  libc6
WARNING
: The following essential packages will be removed.
This should NOT be done unless you know exactly what you are doing!
  apt adduser
(due to apt) libapt-pkg5.0 (due to apt) libgnutls30 (due to apt) bsdutils libsystemd0 (due to bsdutils) coreutils e2fsprogs libblkid1 (due to e2fsprogs)
  libuuid1
(due to e2fsprogs) fdisk libfdisk1 (due to fdisk) libmount1 (due to fdisk) libsmartcols1 (due to fdisk) init systemd-sysv (due to init) libc-bin login
  libpam
-runtime (due to login) libpam-modules (due to login) mount util-linux (due to mount) sysvinit-utils libudev1 (due to util-linux)
0 upgraded, 0 newly installed, 1 downgraded, 291 to remove and 0 not upgraded.
Need to get 2584 kB of archives.
After this operation, 839 MB disk space will be freed.
You are about to do something potentially harmful.
To continue type in the phrase 'Yes, do as I say!'
 
?] ^C


@Vladimir, Thank you...
I'll check with docker solution if I'm not able to figure out otherwise... For now I would like to run the build directly, as otherwise I'll have to modify CI/CD integration as well :)



On Saturday, August 1, 2020 at 6:34:37 PM UTC+2, Kushtrim Pacaj wrote:

I am trying to setup a new build server for AOSP and ran into problems setting up the environment.
I've done this lots of times without problems, but something seems to have changed.

This is a fresh install of Ubuntu 18.04.4 LTS.
What I'm trying to install is this ( from this link https://source.android.com/setup/build/initializing )


sudo apt-get install git-core gnupg flex bison build-essential zip curl zlib1g-dev gcc-multilib g++-multilib libc6-dev-i386 lib32ncurses5-dev x11proto-core-dev libx11-dev lib32z1-dev libgl1-mesa-dev libxml2-utils xsltproc unzip fontconfig


This is the output:  

Building dependency tree      

Reading state information... Done

fontconfig is already the newest version (2.11.94-0ubuntu1.1).

fontconfig set to manually installed.

curl is already the newest version (7.58.0-2ubuntu3.9).

curl set to manually installed.

build-essential is already the newest version (12.4ubuntu1).

build-essential set to manually installed.

gnupg is already the newest version (2.2.4-1ubuntu1.2).

gnupg set to manually installed.

Some packages could not be installed. This may mean that you have

requested an impossible situation or if you are using the unstable

distribution that some required packages have not yet been created

or been moved out of Incoming.

The following information may help to resolve the situation:


The following packages have unmet dependencies:

g++-multilib : Depends: g++-5-multilib (>= 5.3.1-3~) but it is not going to be installed

gcc-multilib : Depends: gcc-5-multilib (>= 5.3.1-3~) but it is not going to be installed

lib32ncurses5-dev : Depends: lib32tinfo5 (= 6.0+20160213-1ubuntu1) but it is not going to be installed

                    Depends: lib32ncurses5 (= 6.0+20160213-1ubuntu1) but it is not going to be installed

                    Depends: lib32tinfo-dev (= 6.0+20160213-1ubuntu1) but it is not going to be installed

                    Depends: libncurses5-dev (= 6.0+20160213-1ubuntu1) but it is not going to be installed

lib32z1-dev : Depends: lib32z1 (= 1:1.2.8.dfsg-2ubuntu4.3) but it is not going to be installed

libc6-dev-i386 : Depends: libc6-i386 (= 2.23-0ubuntu11.2) but it is not going to be installed

                 Depends: libc6-dev (= 2.23-0ubuntu11.2) but 2.27-3ubuntu1.2 is to be installed

libgl1-mesa-dev : Depends: mesa-common-dev (= 18.0.5-0ubuntu0~16.04.1) but it is not going to be installed

                  Depends: libdrm-dev (>= 2.4.74) but it is not going to be installed

                  Depends: libx11-xcb-dev but it is not going to be installed

                  Depends: libxcb-dri3-dev but it is not going to be installed

                  Depends: libxcb-present-dev but it is not going to be installed

                  Depends: libxcb-sync-dev but it is not going to be installed

                  Depends: libxcb-dri2-0-dev but it is not going to be installed

                  Depends: libxcb-glx0-dev but it is not going to be installed

libx11-dev : Depends: libx11-6 (= 2:1.6.3-1ubuntu2.1) but 2:1.6.4-3ubuntu0.2 is to be installed

             Depends: libxau-dev (>= 1:1.0.0-1) but it is not going to be installed

             Depends: libxdmcp-dev (>= 1:1.0.0-1) but it is not going to be installed

             Depends: libxcb1-dev but it is not going to be installed

             Recommends: libx11-doc but it is not going to be installed

zlib1g-dev : Depends: zlib1g (= 1:1.2.8.dfsg-2ubuntu4.3) but 1:1.2.11.dfsg-0ubuntu2 is to be installed

E: Unable to correct problems, you have held broken packages.



--
--
You received this message because you are subscribed to the "Android Building" mailing list.
To post to this group, send email to [hidden email]
To unsubscribe from this group, send email to
[hidden email]
For more options, visit this group at
http://groups.google.com/group/android-building?hl=en

---
You received this message because you are subscribed to the Google Groups "Android Building" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/android-building/dcc94ef1-e4b3-4f81-9081-e586014c2f29n%40googlegroups.com.