[Help] clang error while building on Mac OS X El Capitan

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

[Help] clang error while building on Mac OS X El Capitan

Abhijeet Salunke
I have setup my Mac OS X for building Android. I am able to execute following commands
- source build/envsetup.sh
- lunch 
But when I run "make" it gives me following error:

clang: error: invalid version number in '--mmacosx-version-min=11.1'

My configuration is as follows:
- Mac OS X El Capitan 
- Xcode 12.4
- Mac OS X 11.1 SDK
- JDK 1.8

I have been stuck on this issue for while can anyone help me with these. I have also attached screenshot.

This is my first time building a Android.   

--
--
You received this message because you are subscribed to the "Android Building" mailing list.
To post to this group, send email to [hidden email]
To unsubscribe from this group, send email to
[hidden email]
For more options, visit this group at
http://groups.google.com/group/android-building?hl=en

---
You received this message because you are subscribed to the Google Groups "Android Building" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/android-building/4fdeb00d-070b-41a3-bcc6-90b8c61b2151n%40googlegroups.com.

Screen Shot 2021-02-01 at 5.46.55 PM (1).png (213K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [Help] clang error while building on Mac OS X El Capitan

Dan Willemsen-2
Older versions of Android don't build with newer versions of MacOS (the inverse works, you can build newer android versions with older MacOS versions, though that's not usually interesting except for CI servers)

If you really need to build a 4+ year old android version on your Mac, then your best bet is probably to use a Linux virtual machine. That may be faster anyways.

- Dan

On Wed, Feb 3, 2021 at 9:30 AM Abhijeet Salunke <[hidden email]> wrote:
I have setup my Mac OS X for building Android. I am able to execute following commands
- source build/envsetup.sh
- lunch 
But when I run "make" it gives me following error:

clang: error: invalid version number in '--mmacosx-version-min=11.1'

My configuration is as follows:
- Mac OS X El Capitan 
- Xcode 12.4
- Mac OS X 11.1 SDK
- JDK 1.8

I have been stuck on this issue for while can anyone help me with these. I have also attached screenshot.

This is my first time building a Android.   

--
--
You received this message because you are subscribed to the "Android Building" mailing list.
To post to this group, send email to [hidden email]
To unsubscribe from this group, send email to
[hidden email]
For more options, visit this group at
http://groups.google.com/group/android-building?hl=en

---
You received this message because you are subscribed to the Google Groups "Android Building" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/android-building/4fdeb00d-070b-41a3-bcc6-90b8c61b2151n%40googlegroups.com.

--
--
You received this message because you are subscribed to the "Android Building" mailing list.
To post to this group, send email to [hidden email]
To unsubscribe from this group, send email to
[hidden email]
For more options, visit this group at
http://groups.google.com/group/android-building?hl=en

---
You received this message because you are subscribed to the Google Groups "Android Building" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/android-building/CALQgHdmmnDFLbFVB-eokPm6-12tXzsk1nFmpAuVqB4atN%2BGCGw%40mail.gmail.com.
Reply | Threaded
Open this post in threaded view
|

Re: [Help] clang error while building on Mac OS X El Capitan

Dan Willemsen-2
Oh, I forgot El Capitan is MacOSX 10.11, which is probably old enough to be supported on that branch. But the MacOS 11.1 SDK shouldn't work on that, and the screenshot claims that you're running 10.15.7 (Darwin 19.6.0). So something doesn't line up here.

Regardless, the Linux VM is probably your best bet -- platform builds on Mac aren't entirely full-featured anyways (close enough for most development, but a handful of things can be missing).

- Dan

On Tue, Feb 16, 2021 at 2:07 PM Dan Willemsen <[hidden email]> wrote:
Older versions of Android don't build with newer versions of MacOS (the inverse works, you can build newer android versions with older MacOS versions, though that's not usually interesting except for CI servers)

If you really need to build a 4+ year old android version on your Mac, then your best bet is probably to use a Linux virtual machine. That may be faster anyways.

- Dan

On Wed, Feb 3, 2021 at 9:30 AM Abhijeet Salunke <[hidden email]> wrote:
I have setup my Mac OS X for building Android. I am able to execute following commands
- source build/envsetup.sh
- lunch 
But when I run "make" it gives me following error:

clang: error: invalid version number in '--mmacosx-version-min=11.1'

My configuration is as follows:
- Mac OS X El Capitan 
- Xcode 12.4
- Mac OS X 11.1 SDK
- JDK 1.8

I have been stuck on this issue for while can anyone help me with these. I have also attached screenshot.

This is my first time building a Android.   

--
--
You received this message because you are subscribed to the "Android Building" mailing list.
To post to this group, send email to [hidden email]
To unsubscribe from this group, send email to
[hidden email]
For more options, visit this group at
http://groups.google.com/group/android-building?hl=en

---
You received this message because you are subscribed to the Google Groups "Android Building" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/android-building/4fdeb00d-070b-41a3-bcc6-90b8c61b2151n%40googlegroups.com.

--
--
You received this message because you are subscribed to the "Android Building" mailing list.
To post to this group, send email to [hidden email]
To unsubscribe from this group, send email to
[hidden email]
For more options, visit this group at
http://groups.google.com/group/android-building?hl=en

---
You received this message because you are subscribed to the Google Groups "Android Building" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/android-building/CALQgHdmvbh0uoXcBuoC3jwFbG%3Dt3goaipSpnqpsayfsW0jMrbQ%40mail.gmail.com.
Reply | Threaded
Open this post in threaded view
|

Re: [Help] clang error while building on Mac OS X El Capitan

Abhijeet Salunke
Thanks for the answer Dan Willemsen.. And Yes it was my mistake when I said I am using El Capitan actually I have updated the system and currently its Mac OS X Catalina. I am working with Linux VM as suggested by you.

On Wed, Feb 17, 2021 at 3:42 AM 'Dan Willemsen' via Android Building <[hidden email]> wrote:
Oh, I forgot El Capitan is MacOSX 10.11, which is probably old enough to be supported on that branch. But the MacOS 11.1 SDK shouldn't work on that, and the screenshot claims that you're running 10.15.7 (Darwin 19.6.0). So something doesn't line up here.

Regardless, the Linux VM is probably your best bet -- platform builds on Mac aren't entirely full-featured anyways (close enough for most development, but a handful of things can be missing).

- Dan

On Tue, Feb 16, 2021 at 2:07 PM Dan Willemsen <[hidden email]> wrote:
Older versions of Android don't build with newer versions of MacOS (the inverse works, you can build newer android versions with older MacOS versions, though that's not usually interesting except for CI servers)

If you really need to build a 4+ year old android version on your Mac, then your best bet is probably to use a Linux virtual machine. That may be faster anyways.

- Dan

On Wed, Feb 3, 2021 at 9:30 AM Abhijeet Salunke <[hidden email]> wrote:
I have setup my Mac OS X for building Android. I am able to execute following commands
- source build/envsetup.sh
- lunch 
But when I run "make" it gives me following error:

clang: error: invalid version number in '--mmacosx-version-min=11.1'

My configuration is as follows:
- Mac OS X El Capitan 
- Xcode 12.4
- Mac OS X 11.1 SDK
- JDK 1.8

I have been stuck on this issue for while can anyone help me with these. I have also attached screenshot.

This is my first time building a Android.   

--
--
You received this message because you are subscribed to the "Android Building" mailing list.
To post to this group, send email to [hidden email]
To unsubscribe from this group, send email to
[hidden email]
For more options, visit this group at
http://groups.google.com/group/android-building?hl=en

---
You received this message because you are subscribed to the Google Groups "Android Building" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/android-building/4fdeb00d-070b-41a3-bcc6-90b8c61b2151n%40googlegroups.com.

--
--
You received this message because you are subscribed to the "Android Building" mailing list.
To post to this group, send email to [hidden email]
To unsubscribe from this group, send email to
[hidden email]
For more options, visit this group at
http://groups.google.com/group/android-building?hl=en

---
You received this message because you are subscribed to the Google Groups "Android Building" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/android-building/CALQgHdmvbh0uoXcBuoC3jwFbG%3Dt3goaipSpnqpsayfsW0jMrbQ%40mail.gmail.com.

--
--
You received this message because you are subscribed to the "Android Building" mailing list.
To post to this group, send email to [hidden email]
To unsubscribe from this group, send email to
[hidden email]
For more options, visit this group at
http://groups.google.com/group/android-building?hl=en

---
You received this message because you are subscribed to the Google Groups "Android Building" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/android-building/CAGi07figSdzWke7ypNEiEQ52Q-WmE3K9USH5TVR1RNRwpEkmUA%40mail.gmail.com.