Question regarding hidl implementation

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Question regarding hidl implementation

androidid

Hi,

I am implementing hidl for one of the AOSP components and have a question regarding it. I have different versions of HAL that are provided by the aos/hardware/interfaces/component/ starting from 1.1, 2.0 and 2.1.

As a OEM i am working on AOSP-11 and do i need to provide implementation for all the versions (1.1, 2.0 and 2.1) or providing it for latest version (2.1) would be good enough ?

Can some one help me with this query and/ or point me the google documentation on the same please.

Thanks in advance.

Regards
Girish

--
You received this message because you are subscribed to the Google Groups "android-platform" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/android-platform/21972ff4-ae55-478d-901b-2fd366836ba2n%40googlegroups.com.
Reply | Threaded
Open this post in threaded view
|

Re: Question regarding hidl implementation

rakesh reddy
hi girish,

it is up to you what version you implement.it depends what are all the interfaces you support, but you have to  implement any one of the versions.
you should point it in your manifest file what hal version is supported, so that AOSP will know to use.



On Mon, Dec 14, 2020 at 12:33 PM androidid <[hidden email]> wrote:

Hi,

I am implementing hidl for one of the AOSP components and have a question regarding it. I have different versions of HAL that are provided by the aos/hardware/interfaces/component/ starting from 1.1, 2.0 and 2.1.

As a OEM i am working on AOSP-11 and do i need to provide implementation for all the versions (1.1, 2.0 and 2.1) or providing it for latest version (2.1) would be good enough ?

Can some one help me with this query and/ or point me the google documentation on the same please.

Thanks in advance.

Regards
Girish

--
You received this message because you are subscribed to the Google Groups "android-platform" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/android-platform/21972ff4-ae55-478d-901b-2fd366836ba2n%40googlegroups.com.

--
You received this message because you are subscribed to the Google Groups "android-platform" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/android-platform/CAHzwipTRHZfF8W%3D27EEEWseFJqiTeUgjY_%3D3cSqW7PU-u2Z3oA%40mail.gmail.com.