Re: Emulator/Crespo/Maguro cannot bring up by the build on AOSP

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Re: Emulator/Crespo/Maguro cannot bring up by the build on AOSP

James Douglass Lefruy
Hi all,
I am having a similar with jelly bean compilation  for maguro(GSM/HSPDA+) specially this branch : android-4.1.2_r1. I downloaded the right official Galaxy Nexus drivers and extract them. 
I didn't do any compilations for any other target after the repo sync command. After compilations with a lunch for full full_maguro-userdebug. It results into system.img which lacks some system executables(dextopt, iptables, ip6tables) and some libraries it should have contain. I flash my Galaxy Nexus phones and it kept looping the boot animations with these logcats errors from adb, please tell me what may be the cause that it always skips to include those libraries and executables even though I am able to see their intermediate files either in out/target/product/maguro/obj/EXECUTABLES/, out/target/product/maguro/symbols/system/bin/ or out/target/product/maguro/symbols/system/lib
Please, any help.
12-13 10:25:34.734: E/BandwidthController(15720): runIptablesCmd(): failed /system/bin/iptables -N bw_INPUT res=32512
12-13 10:25:34.734: E/BandwidthController(15720): runIptablesCmd(): failed /system/bin/ip6tables -N bw_INPUT res=32512
12-13 10:25:34.734: E/BandwidthController(15720): runIptablesCmd(): failed /system/bin/iptables -A bw_INPUT -i lo --jump RETURN res=32512
12-13 10:25:34.734: E/BandwidthController(15720): runIptablesCmd(): failed /system/bin/ip6tables -A bw_INPUT -i lo --jump RETURN res=32512
12-13 10:25:34.859: W/EffectsFactory(15719): loadLibrary() failed to open /system/lib/soundfx/libaudiopreprocessing.so
12-13 10:25:34.859: W/EffectsFactory(15719): loadLibrary() failed to open /system/lib/soundfx/libdownmix.so
12-13 10:25:34.859: W/EffectsFactory(15719): loadEffect() could not get library downmix
12-13 10:25:34.859: W/EffectsFactory(15719): loadEffect() could not get library pre_processing
12-13 10:25:34.859: W/EffectsFactory(15719): loadEffect() could not get library pre_processing
12-13 10:25:34.859: W/EffectsFactory(15719): loadEffect() could not get library pre_processing
12-13 10:25:34.859: E/AudioMixer(15719): unable to find downmix effect
12-13 10:25:39.125: E/dalvikvm(15797): execv '/system/bin/dexopt' failed: No such file or directory
12-13 10:25:39.132: W/dalvikvm(15795): DexOpt: --- END 'framework.jar' --- status=0x0100, process failed
12-13 10:25:39.132: E/dalvikvm(15795): Unable to extract+optimize DEX from '/system/framework/framework.jar'
12-13 10:25:39.609: E/dalvikvm(15798): execv '/system/bin/dexopt' failed: No such file or directory
12-13 10:25:39.609: W/dalvikvm(15795): DexOpt: --- END 'android.policy.jar' --- status=0x0100, process failed
12-13 10:25:39.609: E/dalvikvm(15795): Unable to extract+optimize DEX from '/system/framework/android.policy.jar'
12-13 10:25:39.679: E/dalvikvm(15799): execv '/system/bin/dexopt' failed: No such file or directory
12-13 10:25:39.687: W/dalvikvm(15795): DexOpt: --- END 'services.jar' --- status=0x0100, process failed
12-13 10:25:39.687: E/dalvikvm(15795): Unable to extract+optimize DEX from '/system/framework/services.jar'






Le mardi 14 août 2012 19:28:32 UTC+2, Roger Chen a écrit :
Hi All,

I built the emulator/crespo/maguro images based on the newest AOSP code. But it seems all of them cannot bring up.

Did any changset break this?
Following as the log in emulator.

08-14 17:22:12.192: E/BatteryService(470): usbOnlinePath not found
08-14 17:22:12.192: E/BatteryService(470): batteryVoltagePath not found
08-14 17:22:12.192: E/BatteryService(470): batteryTemperaturePath not found
08-14 17:22:14.373: E/dalvikvm(470): /system/app/SettingsProvider.apk odex has stale dependencies
08-14 17:22:14.373: E/dalvikvm(470): odex source not available -- failing
08-14 17:22:14.383: E/dalvikvm(470): /system/app/SettingsProvider.apk odex has stale dependencies
08-14 17:22:14.393: E/System(470): ******************************************
08-14 17:22:14.393: E/System(470): ************ Failure starting core service
08-14 17:22:14.393: E/System(470): java.lang.RuntimeException: Unable to get provider com.android.providers.settings.SettingsProvider: java.lang.ClassNotFoundException: com.android.providers.settings.SettingsProvider
08-14 17:22:14.393: E/System(470): at android.app.ActivityThread.installProvider(ActivityThread.java:4563)
08-14 17:22:14.393: E/System(470): at android.app.ActivityThread.installContentProviders(ActivityThread.java:4190)
08-14 17:22:14.393: E/System(470): at android.app.ActivityThread.installSystemProviders(ActivityThread.java:4706)
08-14 17:22:14.393: E/System(470): at com.android.server.am.ActivityManagerService.installSystemProviders(ActivityManagerService.java:6706)
08-14 17:22:14.393: E/System(470): at com.android.server.ServerThread.run(SystemServer.java:204)
08-14 17:22:14.393: E/System(470): Caused by: java.lang.ClassNotFoundException: com.android.providers.settings.SettingsProvider
08-14 17:22:14.393: E/System(470): at dalvik.system.BaseDexClassLoader.findClass(BaseDexClassLoader.java:61)
08-14 17:22:14.393: E/System(470): at java.lang.ClassLoader.loadClass(ClassLoader.java:501)
08-14 17:22:14.393: E/System(470): at java.lang.ClassLoader.loadClass(ClassLoader.java:461)
08-14 17:22:14.393: E/System(470): at android.app.ActivityThread.installProvider(ActivityThread.java:4548)
08-14 17:22:14.393: E/System(470): ... 4 more
08-14 17:22:14.423: A/SystemServer(470): BOOT FAILURE starting Input Manager Service
08-14 17:22:14.423: A/SystemServer(470): java.lang.RuntimeException: Unable to get provider com.android.providers.settings.SettingsProvider: java.lang.ClassNotFoundException: com.android.providers.settings.SettingsProvider
08-14 17:22:14.423: A/SystemServer(470): at android.app.ActivityThread.installProvider(ActivityThread.java:4563)
08-14 17:22:14.423: A/SystemServer(470): at android.app.ActivityThread.acquireProvider(ActivityThread.java:4230)
08-14 17:22:14.423: A/SystemServer(470): at android.app.ContextImpl$ApplicationContentResolver.acquireProvider(ContextImpl.java:1688)
08-14 17:22:14.423: A/SystemServer(470): at android.content.ContentResolver.acquireProvider(ContentResolver.java:1083)
08-14 17:22:14.423: A/SystemServer(470): at android.provider.Settings$NameValueCache.getString(Settings.java:727)
08-14 17:22:14.423: A/SystemServer(470): at android.provider.Settings$Secure.getString(Settings.java:2343)
08-14 17:22:14.423: A/SystemServer(470): at com.android.server.InputMethodManagerService.<init>(InputMethodManagerService.java:618)
08-14 17:22:14.423: A/SystemServer(470): at com.android.server.ServerThread.run(SystemServer.java:287)
08-14 17:22:14.423: A/SystemServer(470): Caused by: java.lang.ClassNotFoundException: com.android.providers.settings.SettingsProvider
08-14 17:22:14.423: A/SystemServer(470): at dalvik.system.BaseDexClassLoader.findClass(BaseDexClassLoader.java:61)
08-14 17:22:14.423: A/SystemServer(470): at java.lang.ClassLoader.loadClass(ClassLoader.java:501)
08-14 17:22:14.423: A/SystemServer(470): at java.lang.ClassLoader.loadClass(ClassLoader.java:461)
08-14 17:22:14.423: A/SystemServer(470): at android.app.ActivityThread.installProvider(ActivityThread.java:4548)
08-14 17:22:14.423: A/SystemServer(470): ... 7 more
08-14 17:22:14.433: A/SystemServer(470): BOOT FAILURE making display ready
08-14 17:22:14.433: A/SystemServer(470): java.lang.NullPointerException
08-14 17:22:14.433: A/SystemServer(470): at com.android.server.ServerThread.run(SystemServer.java:303)
08-14 17:22:14.453: E/AndroidRuntime(470): *** FATAL EXCEPTION IN SYSTEM PROCESS: android.server.ServerThread
08-14 17:22:14.453: E/AndroidRuntime(470): java.lang.NullPointerException
08-14 17:22:14.453: E/AndroidRuntime(470): at com.android.server.am.ActivityManagerService.showBootMessage(ActivityManagerService.java:4187)
08-14 17:22:14.453: E/AndroidRuntime(470): at com.android.server.ServerThread.run(SystemServer.java:315)
08-14 17:22:14.473: E/installd(41): eof
08-14 17:22:14.473: E/installd(41): failed to read size
08-14 17:22:15.313: E/BandwidthController(494): runIptablesCmd(): failed /system/bin/iptables -N bw_INPUT res=768
08-14 17:22:15.333: E/BandwidthController(494): runIptablesCmd(): failed /system/bin/ip6tables -N bw_INPUT res=768
08-14 17:22:15.662: E/BandwidthController(494): runIptablesCmd(): failed /system/bin/iptables -A bw_INPUT -i lo --jump RETURN res=768
08-14 17:22:15.692: E/BandwidthController(494): runIptablesCmd(): failed /system/bin/ip6tables -A bw_INPUT -i lo --jump RETURN res=768
08-14 17:22:15.692: E/Netd(494): Unable to bind netlink socket: No such file or directory
08-14 17:22:15.692: E/Netd(494): Unable to open quota2 logging socket

Thanks,
Roger

--
You received this message because you are subscribed to the Google Groups "android-platform" group.
To view this discussion on the web visit https://groups.google.com/d/msg/android-platform/-/-9av0n1X1VAJ.
To post to this group, send email to [hidden email].
To unsubscribe from this group, send email to [hidden email].
For more options, visit this group at http://groups.google.com/group/android-platform?hl=en.