ndk-build problem in Eclipse

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

ndk-build problem in Eclipse

Thomas Martitz
Hello,

I have a android application project (java) to which I added "native
support" using Eclipse and ADT.

My problem is: After some time building (the entire app, including jni
code) with Eclipse stops working with the following error message:

> 23:42:33 **** Incremental Build of configuration Debug Native for
> project ares-remote-app ****
> /home/kugel/share/android-ndk-r8c/ndk-build
> Cannot run program "/home/kugel/share/android-ndk-r8c/ndk-build":
> Unknown reason
>
> Error: Program "/home/kugel/share/android-ndk-r8c/ndk-build" not found
> in PATH
> PATH=[/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games:/home/kugel/share/android-ndk-r8c]

ndk-build cannot be run anymore. That is very strange as building works
flawlessly the first couple of builds. It also still works (and
successfully compiles the native library) from the command line. After
restarting eclipse, building works again for a few builds (after some
builds the problem appears again).

I'm running eclipse 3.8 with ADT v21, SDK v21 and NDK r8c.

Does anyone else suffer from the same issue?

Best regards.

--
You received this message because you are subscribed to the Google Groups "android-ndk" group.
To post to this group, send email to [hidden email].
To unsubscribe from this group, send email to [hidden email].
For more options, visit this group at http://groups.google.com/group/android-ndk?hl=en.