screenrecord fails in capturing frames on oreo8.1?

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

screenrecord fails in capturing frames on oreo8.1?

Ganesh Biradar
Hi Guys,

I am trying to use screenrecord command tool to record video of screen surface but screenrecord not capturing single frame.

I don't see any avc denial or error which will pinpoint to where is the issue.

So i have enable debug logs in screenrecord as well as surfaceflinger.

Main display is 480x854 @60.00fps (orientation=0)
Display is 480x854 @60.00fps (rotated=0)
Configuring recorder for 480x854 video/avc at 4.00Mbps
Creating codec
Success: able to create video/avc codec instance
Success: able to configure video/avc codec at 480x854 (err=0)
Creating encoder input surface
Starting codec
Codec prepared
prepareEncoder with @60.00fps and err: 0
Not using rotated width/height
Content area is 480x854 at offset x=0 y=0
recordScreen: FORMAT_MP4:0 gRotate:0
able to get output buffers (err=0)
Calling dequeueOutputBuffer
dequeueOutputBuffer returned -11

Issue seems in dequeueOutputbuffer same error printing multiple times(-EAGAIN).

logcat:

01-01 03:00:40.058  9214  9214 V MediaCodec: dequeueOutputBuffer - -11
01-01 03:00:40.059  9214  9214 V ScreenRecord: Got -EAGAIN, looping

On oreo 8.0, it is working fine but on oreo 8.1 failing.
Tried capturing raw-frames using screenrecord but same result no frame captured.


any input where can i look for the problem.


 

--
You received this message because you are subscribed to the Google Groups "android-platform" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at https://groups.google.com/group/android-platform.
For more options, visit https://groups.google.com/d/optout.